Who's online: noctm, Soapbox2627, spacewolf, steelo, Guests: 141
  • Yahitsme Posts: 1
    Stock Poster Yahitsme
    20 Jul 2019 09:52 AM
    So I’m new to owning a Harley, picked up my new street 500 just over a month ago and admittedly have had it sitting in the shed the whole time cause I’m still on my Ls.
    Anyway today I tried to start it up as I was meant to be doing my RE license test and the thing just hummed for a moment, clicked and that was it. If I hold the ignition on, the bike just clicks intermittently. 
    The Fuel gauge, engine, abs and oil lights are on and the security system is deactivated.
    It feels as if this is a battery problem, has anyone else had this or know how to fix it ? 
  • fatbat Posts: 2840
    Forum Legend fatbat
    20 Jul 2019 10:24 AM
    Probably a flat battery. Roll start it or jump it off another battery. Then take it for a decent ride to recharge it. Buy a trickle charger and use it. 
  • Ratbob Posts: 1061
    Adelaide Hills
    Performance Poster Ratbob
    20 Jul 2019 10:39 AM
    Hi Yahitsme welcome to the forum. 
    As Fatbat said get a battery tender, your bike’s running an alarm system that’s always drawing power and if you parked it up as a brand new bike the battery probably wasn’t fully charged from the shop. They’d be expecting you to ride it.
    Let us know how you went.
  • mickle Posts: 2006
    Meadow Heights Victoria
    Motor Head mickle
    20 Jul 2019 11:03 AM
    As above, these are renowned for having a cheap shitty battery, if left for any period of time they
    need to be on a tender. As Bat said push her down the hill and jump on it will recharge then keep
    her on a battery tender.
© 2019 - 1.0.4.2