Who's online: Guests: 851
  • markmckenz Posts: 36
    Perth, WA
    Stock Poster markmckenz
    22 May 2020 11:53 PM
    I was driving home tonight, I knew there was something wrong with the bike as like when you can ‘just tell’. The Lo Range text then appeared on the speedo, coupled with the flashing fuel light and the steady red light.

    At the same time the fuel gauge went from ½ tank to EMPTY!! I filled her up to be sure in case I was leaking fuel and I was corrrect.. $8! So it definately didnt need fuel it and its still displaying it now. 

    Any suggestions?
    HD Forums Australia - 1F5D36CF-08EF-45D2-8C0B-9D7C1542D7CE.jpeg

  • wello Posts: 497
    Stage 1 Poster wello
    23 May 2020 12:22 AM
    Quoting markmckenz on 22 May 2020 11:53 PMedited: 23 May 2020 08:47 AM
    I was driving home tonight, I knew there was something wrong with the bike as like when you can ‘just tell’. The Lo Range text then appeared on the speedo, coupled with the flashing fuel light and the steady red light.

    At the same time the fuel gauge went from ½ tank to EMPTY!! I filled her up to be sure in case I was leaking fuel and I was corrrect.. $8! So it definately didnt need fuel it and its still displaying it now. 

    Any suggestions?
    HD Forums Australia - 1F5D36CF-08EF-45D2-8C0B-9D7C1542D7CE.jpeg

    quite possibly the battery or a connection .. dirty or loose etc 
    check out this site .
    https://www.hdforums.com/forum/softail-models/1128431-im-getting-a-lo-rng-signal-help.html
  • beaglebasher Posts: 1171
    Performance Poster beaglebasher
    23 May 2020 06:48 AM
    Turn the ignition off for one minute. 
    Or two..
    Should sort itself out.
© 2020 - 1.0.4.2